Alister West

home is where your code is ...

Devel::REPL (re.pl) - A moose interactive interpreter.

To make re.pl work 'well' you need libtermcap, libreadline-dev, and a bunch of other yaks on your system. Check the failure logs from cpanm.

# ~/.re.pl/repl.rc
#
# used as default by re.pl

use 5.010.1;

use Data::Dumper;
use Data::Dump qw/Dump/;

$_REPL->load_plugin($_) for qw( 
    Colors
    Commands
    DDS
    History
    LexEnv
    MultiLine::PPI
    Packages
);

# End

h3. See Also

perl -de 0
perl -MDevel::REPL::Script=run  # Moose Interactive 
irb    # ruby interpreter
python # python interpreter
By Alister West